fnhp.net
当前位置:首页 >> 编译升级php >>

编译升级php

进入php源程序目录中的ext目录中,这里存放着各个扩展模块的源代码,选择你需要的模块,比如curl模块:cd curl 执行phpize生成编译文件,phpize在PHP安装目录的bin目录下 /usr/local/php5/bin/phpize 运行时,可能会报错:Cannot find autoconf.

你是windows的话,下载一个,重新集成到Apache中.如果你是linux的话,你如果是用快捷安装,如Ubuntu 的apt-get安装,你再apt-get一次.如果是centos的话,你就yum install如果 是编译的,你就到php.net下载php-5.3下来重新编译,记得先看一下5.2的编译参数,然后应用到5.3上再编译就可以了.

这个要看你原来是什么方式安装的,通常有以几种:1、rpm方式安装的,那就找一下新的php的rpm安装包通常首选U选项,因为它:可以安装新包,如果已安装了该软件包的旧版本,则该选项可以更新已安装的软件包.而i选项只是尝试安装指定的软件包,如果跟已安装的包有冲突,那么安装将失败.2、源代码编译方式.你可以先查看一下中的Configure Command.知道旧的使了什么参数,记录下来.然后下载新的代码,用旧的参数重编译一次,安装就可以.3、yum的方式安装.那最简单,再yum update php就可以了,其它会自动完成.

PHP-FPM是一个PHP FastCGI的管理器,它实际上就是PHP源代码的补丁,旨在将FastCGI进程管理引进到PHP软件包中,我们必须将其patch到PHP源代码中,然后再行编译才能使用.而现在我们可以在PHP 5.3.2及更新版本中直接开启并使用即可,因为PHP从该版本已经将其收入到软件包中,所以其不再是补丁包的存在了.

目录在你安装的地方,想想当时你装在哪里了一般在c盘或者d盘下面,就能看到有个php的文件夹了,这个就是php的目录升级的话,到官网上去下载想要的版本,再按教程来配置就ok

PHP和升级系统没有关系,但是你升级系统要保留你现在的个人数据应用,只要你的PHP在升级系统之前能跑起来就没有问题

从新编译一遍最新的php就可以了

升级的命令是 rpe -U +你要升级的软件包名! 应用在 LINUX 4.0 服务器版上面你的 如果软件包格式不是 RPM 格式的 LINUX 是不支持 安装和 升级的 你必须进行编译之后才可以进行安装和升级,升级的时候最好进入那软件包名的 目录下 进行升级 比如说 你的php是在 home/123/php 这里123 是我新建存放phph软件的 目录 下面是具体命令: cd /home/123 cd/123 rpm -U php 即可完成 如果是要编译的再次不多说,你可以加我Q Q问我 296019056

去官网下载php,windows直接安装linux重新编译PHP!ok

在LNMP目前LNMP v1.2/1.3中已经包含了Nginx、MySQL/MariaDB、PHP的升级脚本,可以帮助搭建对环境中的程序进行升级.(注意:以下操作均需要在lnmp压缩包解压后的目录里运行)一、Nginx升级脚本执行:./upgrade.sh nginx 按提示输

网站首页 | 网站地图
All rights reserved Powered by www.fnhp.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com